Jump to content


Photo

some planes (HSFX) not being seen in class file?


  • Please log in to reply
5 replies to this topic

#1 Widowmaker214

Widowmaker214

    Member

  • Members
  • PipPip
  • 13 posts

Posted 05 May 2015 - 06:05 PM

yeah please dont kill me. I know Ive been out of the  loop for a while.

sorting things :)

so Ive got a couple campaigns doing just fine with DCG 3.48 / IL2 4.12.2 / HSFX 7.03

 

Solved the 'e l' integer error.  Somehow some trash got added to the end of the class.dcg file.

like 5 lines of it.   under neath the country ID to years area..   like   e   l   i  1   0   something like that

so when DCG would try to make a substitute and not find the aircraft it would throw that error.

but still getitng the issue of the planes.

I will post a list at the bottom of this message as to the aircraft.

Its of course HSFX aircraft, but not all of them. SOME work.

The class listings are just fine in DCG,  each aircraft was put in a mission, I use the air.  name and filled out the class file.

The DCG error, is it saying its not finding it in the DCG class file? or is it meaning the aircraft was not found in the GAME class file?

Has anyone else run into this when using DCG with HSFX ? I didnt have such an issue with HSFX 4

 

class file entry example:

 

one mission has a Fairy Fulmar in it. I got the integer issue. Looked at the DCG error file.  said the "FairyFulmar assigned to XX squadron is not present in the class file..."

but here is my Class file entry for it :

 

Fulmar1                        FairyFulmar                         gb 1 2 1 193901 194612 none                           FaireyFulmar                        none                           4000 Meters 280.00 kph  Default     280.00 kph  
 
so I dropped in a Fiat BR 20.  got the same integer error.   "BR_20 assigned to xx squadron is not present in the class file..."

here is my class fore entry for it :

 

FiatBr20                       FiatBR20                            it 2 2 1 193206 194608 none                           BR-20                               none                           3000 Meters 330.00 kph  Default     330.00 kph  
 

 

 

these are the aircraft Ive found a problem with so far.

I can access them just fine in the FMB and used that to pull out the air. name

 

Potez-540

Potez-542
LetovS_328
P-23B
MB-152 Bloch
BattleMkII
Leo_45
B-29sp Silverplate
F4F3s
P61A Late
P61A Early
hurribomber HurricaneMkIIb Bomb
BEAUMKI    BeaufighterMkI
P-23B  PZL23B
P_24F  P24F
P_24G  P24G 
PZL42 P-42
AT6   AT-6
A6M3a_22ko
Avia_B_71 Avia B71
Wellington3  Wellington III
CantZ506B
 G-55-SS0
G-55-SS-Late
J1N1-S
J1N1-Sa
Ju-388-K
He-177-A3
LetovS_328 
LetovS_328N 
FiatBR20
FairyFulmar
 


#2 sniperton

sniperton

    Advanced Member

  • Members
  • PipPipPip
  • 206 posts

Posted 06 May 2015 - 03:47 PM

Check whether you have the corresponding skin folders. DCG needs them.

Check the class file for eventual tabs instead of spaces. DCG hates them.

No more ideas at present  ;)



#3 Widowmaker214

Widowmaker214

    Member

  • Members
  • PipPip
  • 13 posts

Posted 06 May 2015 - 05:27 PM

thanks sniperton... I remembered the TAB issue lol!!!!! but forgot about the skin folders one. I will check on that.

btw.. here is the trash I found at the bottom of the class.dcg file.  I had a copy of the file so I was able to go back and look at it...

Im still trying to figure how it got in there!!!

 

 

Z26                            Zlin-Z-26                           de 1 1 1 194106 194612 none                           Z2-6                                none                           4000 Meters 260.00 kph  Default     260.00 kph  
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        
                                                                   o  o e D  e   l      none                                                               e  t                           ault     Default     Default     Default        


#4 sniperton

sniperton

    Advanced Member

  • Members
  • PipPipPip
  • 206 posts

Posted 06 May 2015 - 09:26 PM

Strange, I've never experienced DCG creating new lines in the class file. Is it not possible that you simply left in some dummies when you made new entries manually? Or you copied some entries from a file encoded for Russian?



#5 Widowmaker214

Widowmaker214

    Member

  • Members
  • PipPip
  • 13 posts

Posted 06 May 2015 - 09:35 PM

you know, I have NOO idea. None of that stuff even looks remotely familiar to anything.  not just that but there was six lines of it.

like I said. no clue where it came from but that was causing the integer error.

as for the others. Yes,THANK YOU. it was the skins folders.  Missing folders and my using _ over - or spelling issue in the skin folder name column.

I actually forgot that was the column for the skin folder name.

I shall leave this up for a while to properly shame myself before deleting the thread lol.

 

Now I have about 60 campaigns to update for the dynamic campaign server!!!



#6 sniperton

sniperton

    Advanced Member

  • Members
  • PipPipPip
  • 206 posts

Posted 07 May 2015 - 12:15 AM

Great, have a good time, and enjoy!  :)






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users