Jump to content

Multiplayer Campaigns Not Working


Recommended Posts

First of all, I'm not really sure where I should have posted this since I'm not really sure what causes the problem. So, sorry in advance if this will be irrelevant here.


One of the ways I most enjoyed playing IL-2 was starting a multiplayer campaign and playing it offline. In that way I could select the formation in which I wanted to fly and also it felt more realistic since you can't switch on autopilot, time compression etc. With the addition of the extra online campaigns brought in with DCG it even became better. 


Later on I've installed HSFX 7.03 and upgraded game version from 4.12 to 4.12.2. The next time I have checked the stock multiplayer campaigns they were all in Russian (not the offline stock/dcg though). I understand that this is a common case with HSFX. I have followed people's advise and added _ru to the file names of the related files in NGEN folder (and also backed up all original _ru and English files without _ru). This turned all campaign names back to English as it was supposed to do do. Howerver, now when I select a new multiplayer campaign (be it DCG or stock) and click on the green 'start' button on the next screen IL-2 gets minimized and I am left staring at the desktop (IL-2 does not crash though). I have put back the original _ru files back, which turns the campaigns back to Russian yet still does not let me start the campaigns. Thus, I started to suspect whether it is a problem related with the installation of HSFX. Disabling all the mods through JSGME once again puts the campaigns into English, but still does not allow starting a new campaign. Therefore, I finally started to wonder whether it is an issue related with DCG.


I'm hoping that I did not stray too far from the issue and I made it easy to understand. Any help would be appreciated.

Thanks in advance all,

Link to comment
Share on other sites

I could swear I did that before posting here, but I apparently did not.  Multiplayer Campaigns are working now again, many thanks to you


Weirdly enough, IL-2 somehow turned back to its original settings with the controls, game & graphic settings all reset and saved campaigns deleted :blink: . But those are all rearrangable.


Have a good day :)

Link to comment
Share on other sites

Im having a very similar problem to this. And   doing Sniperton's suggestion didnt help.

Its been  a while since I ran my own campaigns, but got back into it to update DCG and the game to the lastest versions... (I have  like 50-100 campaigns done up for DCG 3.46 / HSFX 4.1)

so I spent several days  adding all the units from IL2 4.12.2 / HSFX 5-7 into the proper DCG files. was going to update all my campaigns...


I was messing around on my laptop (I have cloned installs on a few computers)...  and I was getting errors with DCG not recognizing new squadrons and making italian planes red with red squadrons and then  that causes teh whole campaign to crash.


then it just didnt work at all.  I get access violation errors from DCG when pointing  to the IL2fb.exe

the allpaints.dcg file grows from 20kb to 56kb and that  generally causes the access viloation error. 


Now all I get is problem duruk had, on all of my machines...

I only use NGen mind you for online coops

If I try and run one of my campaigns.. it does the above or says the front has been lost. If I try a regular DCG campaign it does the above.


I tried going back to stock 4.12.2

tried DCG version 3.47

tried the , out of the box DCG 3.48.16 and 3.47 without any of my own campaign stuff.

still the same thing. when I click on New... IL2 losses focus as I have my mouse on the desk top. when I click back on Il2 you just have to click back.

in the ,missions/net/NGen campaign folder all there is , is a  conf.dat file

and yes, each time I changed IL2 or DCG  I did the uncheck/recheck thing


Im confuuuuusssedddd

Link to comment
Share on other sites

  • 3 weeks later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...