Jump to content

TCapture Command in Timetable


Recommended Posts

Hey Lo,


How are u? Hope all is fine ...


I have an issue i would like to ask about. I suspect the problem is on my side so I would like to know if anybody else is having this issue as well just to make sure.


I have the following commands in my timetable for a custom made campaign:


  19400510 TCapture Axis Luxembourg
  19400510 TCapture Axis Luxembourg_Industrial_District
  19400510 TCapture Axis Sandweiler_Airbase
  19400510 TCapture Axis Ockenburg_Airstrip
  19400510 TCapture Axis Valkenburg_Airbase
  19400510 TCapture Axis Willhemsbrug_North_Bridge706
  19400510 TCapture Axis Willhemsbrug_South_Bridge542
  19400510 TCapture Contested Waalhaven_Airbase
  19400510 TCapture Contested Dordrecht_Bridge708
However when the campaign starts, none of these locations belong to the blue side as they should. Am I typing it wrong? Could the a misspelled rds file cause this type of problem? 
All other commands in the timetable for that particular date work including the NewsBrief, NewColumn, etc ... Only the Tcapture is not working
Link to comment
Share on other sites

What I know about "TCapture":




DATE TCapture "location status" "Location name"

19410802 TCapture Contested Border_Village
19410804 TCapture Allied Border_Village

"location status": Allied, Axis, Contested are the allowed codes.
"Location name": it's the location name according to RDS file.

It's also possible to enforce a change into location control by NewColumn TimeTable command....In fact adding new columns to an enemy controlled location, new columns could conquer the location.



Have a good day...

Link to comment
Share on other sites

Yeah, I also read that Idefix44 and as u can see in the post above the syntax seems to be correct ... And as the other commands work in the time table I think the problem lies in the rds file. The issue here is that I've checked it like 100 times already and I cant find a single misspelling in it. The only thing I can think of is that i didnt align the the waypoints as Tailspin's manual suggests ... What do u think?

Link to comment
Share on other sites

I think that .rds, .rls and other road files are one thing and that the timetable.dcg file is an other one...


May be the use of the TCapture command is it more complicated.

What does I mean?


Saying that you/we can only use Allied/Axis if the location to capture is a pocket of resistance and Contested if the location to capture is on the front line.


About the Home Base location names, I use _Airfield and/or _Airstrip.

You use _Airbase. Does it works fine? Wich kind of planes does it host?


Let me know about TCapture and _Airbase.


Thanks mate

Link to comment
Share on other sites

Thxs for the repply Idefix ...


I tested the command on a different campaign (Poland39, which is a default campaign) and the same thing happens. The command is just simply ignored by the DCG system. I also introduced a NewsBrief command and that one worked fine for the same date. I guess there is something more to it like u said .... Well, lets see with Lo can give us a hand ....

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 months later...

Sorry for no repplying before but i have been away from il2 for a little while. Now that im back, I decided to continue with my custom campaign and back to testing some of dcg features including the TCapture command. From all my testing with the Timetable command set to both On and Off I noticed the same behaviour:


The location asosociated with the command turns to the corresponding side but when the mission is generated it remains on the previous side territory. In other words, the front line is not updated with the TCapture location. I checked the territory.dcg and it appears the command only sets the balance of the troops as X vs 0 at the location but the front line code remains 0 and doesnt switch to either 1 or 2. Is this the way the command is suppose to work or is it a bug?


Thxs Lo





Link to comment
Share on other sites

  • 2 years later...

I am experiencing the same problem with stable 3.48. There are blue front markers at TCapture locations which means that they do change ownership but the red ones remain as well resulting in an unchanged frontline. The weird thing is that it works in standalone mode when you manually press the button to generate missions. If it's used in full auto-generation mode with dcg replacing dgen, it doesn't.


Help please?

Link to comment
Share on other sites

Turns out that it works if the Active Front option is disabled.


EDIT: Unfortunately, I was wrong. TCapture doesn't work if in full auto generation mode. If I run it manually and press the generate mission button, TCapture works and the frontlines are updated accordingly.

Link to comment
Share on other sites

  • 4 weeks later...

Active Front only creates stationary objects (usually anti-tank guns) to create a "battle" at a contested location even though there may be no columns present.


It may be that the code only adds troops to the location but doesn't actually flip it to the side the troops are on.  I haven't touched that code in years so I can't say for sure.  I'll have to get back to you.  (Hopefully sooner than I got here in the first place!)

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...