Jump to content

Campaigns ends too early


Hunt82

Recommended Posts

I playing long time in Il2 and DCG but for some time any campaign I run ends after about 2-3 missions. I done see why. It says something like "Soviet forces have retreated from the sector. The campaign has ended" .All options are the same that was. Ends even campaigns that I finished many times with a lot of missions.Maximum troop number is 10000.

in fact here is dcg ini

 

 

G:\GAMES\il2dcg348\
G:\GAMES\il2dcg348\Kursk_DE\
G:\GAMES\IL-2 Complete Edition\
Two
Default
Default
Default
Heavy
Dense
Dense
Squadron Defaults
400 Kilometers
Default
Default
MassedBombers=False
FrontMovement=True
CopyMission=False
Dogfight=False
Coop=False
Not Used
AutoGeneration=False
Primary=True
DSTimes=True
Paras=True
Briefing=True
ShipRoF=10.0
HistDates=False
ThirdPartyServer=None
LogFileDate=[12.07.2016 13:47:31]
Tracking=True
NoTransfers=False
Night=False
DGEN_Replacement=False
TankDG=False
TransitAlt=Default
TgtEgressAlt=Transit Altitude
TgtAlt=Transit Altitude
TgtIngressAlt=Transit Altitude
IPAlt=Transit Altitude
TgtIngressOffset=Default
IPOffset=Default
TOStepAltBox=Default
NormandyBase=True
Death=True
AirStarts=True
TOCircle=Only Escorts & Escorted
IECoordinates=Only Level Bombers Use
CruiseSpeed=Default
Language=English
GameID=1946
NGEN_Replacement=False
SingleMap=True
PalmTrees=True
RuSupplyRate=7/Squadron/Week
DeSupplyRate=7/Squadron/Week
TrackPlayerRanks=True
AircraftDowngrades=False
LinkMax=False
DataFiles=G:\GAMES\il2dcg348\Data\
DeShipSkill=Average
RuShipSkill=Average
ShipSunk=False
ActiveFront=True
DDRoF=10.0
BridgeRepairTime=1 Mission
BornPlaceRadius=3000
TimePassage=Normal
ServerInfo=
ServerActive=False
Balance=Default
SCPlaneLimits=No
SCTimeLimits=No Time Limit
SquadronManagement=True
IngressSpeed=Default
FixedStartDates=False
CountStaticPlanes=Yes
VoteLevel=100
Radio=Campaign Default
RandomNoseArt=False
NoUserLoadout=False
BeachheadResets=False
MDS=True
RUProp=No
StaticPlanes=No Spawn
NativeRuProp=False
DSMinutes=Default

 

 

I have suspicsons that it started afet some of latest daidalos' patches...

Link to comment
Share on other sites

 You might want to uninstall DCG and reinstall it.

I already did it. Many times! This bag firstly appeared on 3.47. I didnt use 3.48 betas, And some days ago I install new last 3.48. This issue now happens EVERYTIME INN EVERY COMPANY.

When I begin new campaign when I finishes new mission imidiately after it begins everything is ok, there is new generated mission next and so on. But if I flew it normally, and there will be any events, planes fighting, destroyed columns, it always ends in that way!

Link to comment
Share on other sites

I found an old 3.47, actually seems it is the very early beta 3.48, it works fine, without any problem! Then i install beta of 3.49- it dont work properly again! Again when i flew the first mission and some fights happen it says that one side was ouf from map and so on! Old version of DCG works fine, but new are bugged, new from 3.48 and next!

On 3.49 i tryed this trick, i began a new campaign but i didnt check "off-line carrier" on, but when i exited a mission, i minimized the game, run dcg and pressed "generate mission" manually. then i closed dcg and returnes to the game and began a new mission. May be this way will be better, but i now tired to clarify this, i'm sick of a permanent creation and deleting new campaigns without any result. :angry:

Link to comment
Share on other sites

Oh, you really helped me, you absolutely wasnt curious about what i did, you didnt ask any files from me, nothing. You just said me that this is my fault and this is my problem. THANK YOU!

What can i do wrong, it is just if run new dcg it ended after first mission, and when run old dcg it works absolutely normally, as it was in last. THAT'S ALL!

Both the times i just unpack folders, then selectin where game is. What can i do wrong if i had did it before a lot of times? If i so stupid that i cannot unpack an archive why it works with old ones? I installed new version, i'm deleting old campaings from ru, de and other campaigns folder. I check option so and so, in this way, and that way, and all result is after I am sitting staring in a monitor loosing 20 or 30 minutes of my life i get the scoffing message " forces blablabla the war ended hahaha". I even tryed to do so: i installed an old woked version, played it, made sure all is ok. then i took all files from the new unworked version and copied them over the good ones. i didnt take new folder, just pasted them over there to save the path. And- voila- it dont work now ahahah! and for sure the bug is on my end!

the points is:

1. i'm stupid and i cant install new dcg, but somehow old version (that i founded in my reserves) works OK, my stupidity probably doesnt influence on them.

2. If i end mission quckly after it launched THE CAMPAING CONTINUES AND NEW MISSION GENERATES! Campain ends prematurely if missions last a period enough some events occur.

 

here is that last working version

https://mega.nz/#!Vg1CSQiZ!-uOXSrKT1jUj4IWEDFnTZUCpIdA-vJcxo5PvZgkVTL0

all that was newer- doesnt work normally. it was saved by me just in this form as in the archive. I unpacked it, deleted old campaigns, launched new- and all is fine!
 

Link to comment
Share on other sites

Check your "G:\GAMES\IL-2 Complete Edition\" folder for a dcg.ini file.  If it's in there, delete it.  Then delete the one in your DCG folder. 

 

Generate a new campaign using the DGen Replacement mode using these steps:

 

1. Run DCG and select the path of your game, for example: "G:\GAMES\IL-2 Complete Edition\"
2. Select the "Off-Line Career Auto-Generation" mode from the DCG Menu "Mode".
3. Select "Replace Career Generator (DGen)" from the DCG Menu "Mode" and click "Yes". Close DCG.
4. Run IL-2 "Forgotten Battles" and select "Pilot Career".
5. Select any of the stock or DCG campaigns available that is designated "*" and "(DCG)".
6. Play the campaign...

 

 

Link to comment
Share on other sites

I've downloaded it.

It seems that the last time you run a mission was in january 2015, the 10th (Kyushu45_JA).

Are you sure that all works fine now (07/16/16)?

Did you read that i have wrote above?

"it was saved by me just in this form as in the archive. I unpacked it, deleted old campaigns, launched new- and all is fine!"

Do you understand? Some months ago, I downloaded a beta from this forum. I run it, made sure that is working. After i played some campaingns i took this folder from my pc, packed it and saved on a dvd. I dont remember why i didnt save an original archive from this site, maybe i have it somwhere but now i found this one. And now I unpacked it, DELETED OLD "a mission was in january 2015, the 10th (Kyushu45_JA)" I DELETED IT AND BEGINNING NEW!!!!

Link to comment
Share on other sites

 a dcg.ini file. 

I forgot to say, when i had tried to make a new installation of DCG i deleted it. Useless. I do in a such way. I deleted an old dcg folder comepletely, nothing left, in IL2 folder i deleted all dcg folders that keeps in Missions\Campaign\RU and DE and all anothers, and deleted dcg.ini in the main game folder. I would delete anything else, but i dont know what. Maybe something in the register? I dont know. I tried many times. again and again and again again again again.

I didnt use usually "Auto-Generation" mode", OK i will try it. I think i will test one more thing, i will take that release that working and will copypaste files from 3,48 partially and will look which displacement will make the failure. it just requires times, i already dont do anything but this ... :wacko:

and one more thing, i have two os on my pc, xp as reserve and win7x64. The issue happens in both places. Absolutely identical.

Link to comment
Share on other sites

I recommend you try auto-generation mode.  The only reason I haven't disabled the manual way for off-line campaigns is for users of the original IL-2 game (if any are still out there).

Man, But I used EXACTLY auto-generation mode. I thought this was obvious... Just when i use Auto-generation mode a campaign ends after one battle...this is my fault, I didnt explain it. Only manual way works as I need!

But I do wrote abot it here... http://forum.jg1.org/topic/4114-campaigns-ends-too-early/?do=findComment&comment=23390

here it was

"On 3.49 i tryed this trick, i began a new campaign but i didnt check "off-line carrier" on, but when i exited a mission, i minimized the game, run dcg and pressed "generate mission" manually. then i closed dcg and returnes to the game and began a new mission. May be this way will be better,"

 

 

Ok. look.

I have made some test today and yesterday.

1. "Full Off-Line Career Mode." This is when we are replacing stock generator. It works fine. Without any problem. Absolutely. But to be honest this isnt my choice.I'm not satisfied with I cannot set up every options in the campaign as I need. Too simple.

 

2. "Manual Mission Generation Mode". This is when

 

Manual Mission Generation Mode (Pilot Career, Single Mission, Coop, or Dogfight).

 

1. Run DCG.

2. Select the mission mode: Coop, or Dogfight or Single Player Manual (SPManual = no mode checked).

3. If this is a new campaign, click on the "World" icon, otherwise skip to #6.

4. From the drop-down box that appears, select the campaign.

5. Click on the "Start Button".

6. Make any other changes such as squadron, plane, weather, etc.

7. Click the Generate Mission button.

8. Run IL2/FB and fly the mission.

9. When you are finished flying the mission, ALT + TAB out of IL2/FB and manually generate a new mission.

 

It works too, at least about 4 or 5 missions. It works, but it is inconveniently a bit, alt-tab and so on. BUT IT WORKS FINE TOO.

 

3. Off-Line Career Mode. this is when

 

1. Run IL2 DCG.

2. Turn off the off-line Career (Auto-Generation) Mode.

3. If starting a new campaign, click the "Globe" icon.

4. From the drop-down box that appears, select the campaign.

5. Click on the "Start Button".

6. Make any other changes such as squadron, plane, weather, etc.

7. Generate one mission by hitting the DCG "Generate Mission" button.

8. Run IL2 Forgotten Battles.

9. Start a new career with the Nationality you want to fly. DCG should appear as one of the options. Select it.

10. Return to the Main Menu and minimize FB by Alt+Tab (or Exit FB altogether).

11. Turn on DCG's off-line Career (Auto-Generation) Mode. Press the "Generate Mission" button.

12. Close IL2 DCG. The DCG campaign should generate missions automatically from this point on without your having to reconfigure anything..

13. Return to the FB Main screen then re-enter the Career Mode.

 

THIS IS THE ISSUE! This is when any campaign I run ends after about 2-3 missions!

Well, I made an experiment in this mode. I installed that working 3.47. Then I copypasted two folders from 3.48, data and masters (of course with their subfolders). Then I began a new campaign. It ran absolutely normally. Without any problem.

Then I closed il2, and copypasted the new EXE file from 3.48. Then I launched the game, and continued what I had began. And took a mission and finished it.

Man, believe it or not but it showed "Soviet forces have retreated from the sector. The campaign has ended." AGAIN. I understand that you dont want to hear it, you think that I'm harrasing you with silly things and bothering you. But this is the fact, the problem is the new exe...

Well, as you dont trust me and as I understand there will be no fix for my bug I beg you for one thing- please dont disable the manual way for off-line campaigns as you are going. This will be the end for me...

Link to comment
Share on other sites

What is the advantage of manual mode?  If you want to tweak campaign settings before the next mission is generated using the auto-generation mode, you can ALT+TAB out of the game when it's on the debrief screen, run DCG, make all the changes you want in DCG, close DCG, then go back into the game and continue.

 

I do a lot of testing in manual mode myself and I haven't encountered the issue you're having.  The weird thing is, as far as generating missions, there's absolutely no difference between the two.  They use exactly the same code; just triggered in a different way. 

I'll try running some campaigns in manual mode and see if I can get similar results. 

Link to comment
Share on other sites

Man, PLEASE don't take it personally. This simulator is one of the few games Istill playing, and your campaing generator was the best, much much better that the default one. I just wish it works properly but it doesnt on my pc, I have no idea why. It looks like when I'm spendid time in a mission more or less long, the game "forget" something...

Link to comment
Share on other sites

I went so far as to make a video and load it to youtube ;)

https://www.youtube.com/watch?v=g3QoEiyHwIs

Most of the video is a routne, what intertsing is only the  start and the end. No exterior programs, only the game and the video recorder. The campaign is new, my plane controlled by an autopilot. And it is in autogeneration mode of course. And this is the absolutely typical end...

Link to comment
Share on other sites

Hi again. Can you copy the following files here from the Riga campaign folder?  I need to see them before the first mission and then after the first mission (so you'll have to generate them again from the start and then play one mission).

 

campaign.ini

campaign.dcg

territory.dcg

 

Also, I just need this one from after the mission is completed, but before you exit the debriefing screen:

 

log.dcg

 

Thanks!

Link to comment
Share on other sites

ok I'll do it just a bit later, I'm a bit occupied at the moment...

and if I understand correctly-

 

campaign.ini- is from IL-2\Missions\Campaign\RU\DCG

campaign.dcg, territory.dcg, log.dcg - are from \il2dcg348\Riga41_RU

is it right?

 

and my sequence of actions-

1 I start a new campaign, make all changes and generate a new missions

2 I run the game, search the campaign I need, alttab to dcg, turn on auto mode, generate a new mission again

3 AND COPY FILES YOU NEED

4 I close dcg, go to the campaign and finish the mission

5 AND COPY FILES YOU NEED AGAIN?

is it right?

Link to comment
Share on other sites

Thanks, this is perfect.

 

Okay, one weird thing is that you have a dcgerror.txt document in your game folder that's generating date and time but no comment.  If you delete that, does it reappear when you generate a mission?

 

But the reason your campaign ends suddenly is because your territory.dcg and locations.dcg files get corrupt.  For some reason the records drop the "side" value.  For example, before the mission:

Cranz_Airfield 2 allied=0 axis=24
Memel_Factory_District 2 allied=0 axis=20
Memel 2 allied=0 axis=40
Memel_Airfield 2 allied=0 axis=30

And then after the mission:

Cranz_Airfield  allied=0 axis=0
Memel_Factory_District  allied=0 axis=0
Memel 2 allied=0 axis=10
Memel_Airfield 2 allied=0 axis=0

Notice there's no number after both Cranz_Airfield and Memel_Factory_District.

 

Why this is happening, I don't yet know.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...