Jump to content

Problems editing DCG-generated missions in FMB


Recommended Posts

I posted this at SAS and M4T but it was suggested I try here also.
My problem is as fols;
We are running a Western Europe US Fighter campaign (coop, DCG using P-51s using HSFX 7 (no additional modded objects)). Our fighter squadron is co-located with a B-17 Sqn at Boxted.
I would like to change our takeoff formation to "pairs" in order to speed up the fighter takeoff and clear the runway before the bombers start their takeoff run (which crosses our runway).
However, after generating a mission in DCG and going in to FMB I've noticed that;
a. the mission loading pop-up box remains on the screen (i.e. seems to hang...no error message) with only Red flight waypoints showing, and
b. if I cancel/clear the pop-up I can edit what's on the map but the mission only shows the Red air objects (i.e. our waypoints etc). 

I've done a couple of checks by looking at the generated missions in Notepad (the .mis file) before opening in FMB. In Notepad, all the Blue (German) forces, stationary objects etc are there. If I try to open that same file in FMB, everything is gone on the Blue side (and even a lot of the Red stationary/static objects). I can successfully change the takeoff parameters for my fighters but the point is moot as there won't be any enemy objects once I try to save the file!!

So in short: If I try to change anything in the DCG-generated .mis file in FMB and save it using FMB I will lose so much of the original mission as to make it pointless to fly.

The missions run fine if I don't do anything in FMB.  Obviously there's something in the DCG-generated .mis file (I'm guessing) that FMB doesn't like but with no error message I don't know what it could be.


I'm sure there's probably a way around this. Hopefully I explained my predicament clearly enough. Any advice/suggestions is appreciated.



Link to comment
Share on other sites

Just for clarity, here is the file tomoose uploaded as defective:




I guess the file is corrupted (see below). The question is whether it was messed up locally in tomoose's system or DCG failed.


  TAKEOFF 50798.44 328325.64 0 0 &1
  NORMFLY 51071.59 326766.22 1000.00 300.00 &1
  NORMFLY 63141.00 307178.00 6000.0 460.00 &1
  NORMFLY 76266.00 284010.00 6000.0 460.00 &1
  NORMFLY 89691.00 260542.00 6000.0 460.00 &1
  NORMFLY 102517.00 237674.00 5000.0 320.00 &1
  NORMFLY 131587.00 192851.00 5000.0 460.00 &1
  NORMFLY 161257.48 147428.79 5000.0 460.00 &1
  NORMFLY 131797.00 194307.00 5000.0 460.00 &1
  NORMFLY 102936.00 240587.00 5000.0 460.00 &1
  NORMFLY 76476.00 285466.00 5000.0 460.00 &1
  LANDING 50615.21 329746.84 0 0 678_Static 0 0 679_Static 0 0 &1
  TAKEOFF 387120.31 157817.19 0 0 &0 &1
  NORMFLY 387939.12 156593.21 500.00 285.00 &0 &1
  NORMFLY 382717.00 265963.00 6000.0 410.00 &1
  NORMFLY 364395.00 257671.00 6000.0 410.00 &1
  NORMFLY 345173.00 248479.00 6000.0 410.00 &1


After removing erroneous data the file loads correctly (in HSFX FMB).


Link to comment
Share on other sites

LOL, thanks Sniperton, you beat me to it.  I just wanted to post that you solved the problem.  I've posted same at M4T also.


As I stated over at SAS, the problem was probably of my own doing albeit unintentional and unknown.  I created this campaign from scratch and I'm betting that the various other .dcg files that I had to create for the campaign are probably contributing to the problem.  As DCG pulls info/data from these various files in order to generate the next mission.  if I have incorrect or incomplete data in one or more of those files then it follows that it would affect how DCG does its job. 

I don't know enough to explain how that might be happening but I'm sure it's something along those lines.


As the campaign is 'working' so far I think I'll leave the 'master' files alone and simply edit out the offending items in Notepad after DCG generates the mission.


Once again, many thanks.

Link to comment
Share on other sites

It's a bit weird, but the files created by DCG get "cleaned" by the FMB if they're opened in it.  In some cases, they load with few changes and in others, they won't load at all.  It depends on the issue.  I've done some updating of the format in DCG as I come across these problems but there are always more.


I recommend that if it's just the take off formation that you want to modify, you might figure out the format change between the default formation and the pairs and then edit through NotePad rather than the FMB.  It must be a pretty simple change.

Link to comment
Share on other sites


thanks for responding.  "Cleaning" the anomalies in Notepad doesn't take long.  I'll have to look at the .mis file after I've changed the takeoff formation and see what lines need changing.  I tried something similar a while ago but for some reason it didn't work (mission wouldn't load) but perhaps I missed something.



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...