Jump to content
Sign in to follow this  
Treetop64

CTDs and Freezes with DCG v3.46

Recommended Posts

Hello.

 

This has actually been a consistent problem for me in the last few versions of DCG, but I've been afraid to post here for I might have missed something on my end that could have fixed it. Alas, I still get these CTDs from time to time.

 

Regarding version 3.46 DCG:

> Flying default campaign for German Pilot in Eastern Europe, the Riga Autumn map.

 

In addition to this issue also occurring numerous times in the default, unaltered version of the above campaign that comes with DCG...

> Modified Campaign by (Riga Map only):

- In the FMB, moved squadrons to the airfields that I wanted them based at by default.

- Changed all German 1930 20mm Flaks (the old, ugly, unmanned ones) to 1938 20mm Flaks.

- Changed all Soviet 20mm Flaks (the old, ugly, unmanned ones) to the 37mm Flaks.

- Slightly re-positioned many of the AA guns at all the airfeilds.

- Changed all Soviet BT-7 columns to late model T-26s.

- Added a few static ships in the harbors at Memel and Riga (no mobile ships were added -yet- since I'm still learning how that works in DCG).

- Added four new off-map airfields - two each for the red and blue sides - to station level bombers.

> Settings in the DCG interface are mostly default, except for air density (Moderate), Resupply Rate (3 / week for Blue, 1 / day for Red), and weather (Clear to Poor).

 

Running Stock IL-2 1946 v4.11 (No mods were ever installed).

 

About 80% of the time (after numerous, numerous tests), while flying a mission on the very first day of the campaign (June 22, 1941), the game will either lock up and freeze or CTD about 45 minutes to one hour into the mission, about the time AI aircraft are RTB'ing and landing. At this point in the mission, there are one or two slight hesitations and hiccups - a little less than a second in duration each - about every half minute or so. These hesitations continue at the rate described until either I land and end the mission, or the game locks up or CTDs before I can land and end the mission. The latter occurs far more frequently, and when it does DCG's dgen stops and ends as a process in the windows task manager, or, in the case of just freezing without a CTD, I must <ctl/alt/del> out and manually end the dgen process in the task manager. DCG generates an error log in it's root directory but give no information on the CTD/lockup, only the default logs as it generates a mission.

 

Otherwise, IL-2 1946 and - when enabled - it's default DGen (v4.0.8.7) has been running, and continues to run, without a hitch.

 

Basic System Specs:

> Intel i5 750 at 3.2GHz

> 8 GB RAM

> ATI 4770 HD w/512 Mb VRAM

> Enabled "app can handle > 2GB address space" in DCG's dgen.exe with CFF Explorer.

 

I'm at a total loss as to why this keep happening. I've been working at this off and on for more than a year but still cannot isolate the problem. I even turn off my anti-virus while the game is running but it still happens. I hope that you or someone else can give me a hand with this as it's getting frustrating. I've been working on building a new DCG campaign but this is really throwing the proverbial monkey wrench into the project.

 

Thanks!

Share this post


Link to post
Share on other sites

Hi,

I personally had never freezes or CTD during a mission that had something to do with DCG! What you describe reminds me more of a memory problem! Such signs I had often in IL-2 with my old computer and that were always memory issues! The only thing you could bring in connection with DCG would, perhaps too many aircraft and ground units in a mission!

 

Share this post


Link to post
Share on other sites

CTD is a memory related or a graphic driver issue.

Are you running the game in opengl?

What's the version of Catalyst that you have installed?

Are you running any kind of mods?

 

This might be the problem

> Enabled "app can handle > 2GB address space" in DCG's dgen.exe with CFF Explorer.

 

512MB will be more than enough to run this game.

Share this post


Link to post
Share on other sites

Thanks for the replies.

 

@Lonestar:

Memory shouldn't be an issue, system has 8GB of RAM, using Win7 64 bit.

 

@II./JG1_Spies:

Graphics card is ATI 4770 HD with 512MB of VRAM. The card is a couple of years old but it performs well and runs cool. Using Catalyst Version 11.11, and OpenGL Version 6.14.10.11251. Game is run in Perfect Mode under OpenGL. I usually don't upgrade graphics drivers as soon as new versions are available unless I'm experiencing problems, and most of the games I play are older ones anyway. However, the the graphics driver has been upgraded several times while experiencing the issue described in the OP.

 

Also, the problems were occurring well before the .exe was edited with CFF Explorer, and that was only done recently as an act of desperation. I was aware of how much RAM IL-2 uses with DCG running campaigns, about 300 - 350 MB or so, but I figured that it could only help, as it most certainly has with other applications (rFactor with large mods, for instance).

 

No mods were ever installed into IL-2.

 

 

Anyway, as it would happen, I started a new campaign to reproduce the crash and to send the settings and mission files to Lowengrin, and guess what...

.

.

...no crash or stutters in the first two missions. Lol! However, this issue is bound to rear itself again in the future whenever I start a new campaign.

Share this post


Link to post
Share on other sites
Hopefully someone may provide some insight. In the meantime' date=' the next time you get a CTD, email me the mission file that you were flying at the time. I'll check it and see if I can find something wrong in it.[/quote']

 

 

Last mission in the camapign (June 28) CTD'ed about an hour into the mission, while the ones before played fine. Campaign and DCG settings files emailed to you.

 

Thanks for looking into this!

Share this post


Link to post
Share on other sites

After looking at the mission file and then actually flying the mission on autopilot, it looks like the problem is with the waypoints of the HE-111 squadron. It appears to be due to the off map squadrons and their final waypoints.

 

NORMFLY -1499132.00 -574762.00 5500.0 300.00 &1

 

Having removed the final off-map waypoint and played the mission again, I got no CTD even after letting the game run beyond the point it crashed the first time. I think the game has memory issues when planes fly outside of the map bounds....

 

The quick fix is not to use any off-map airfields. This means not using campaigns that have off-map airfields or deleting off-map airfields from those that do (from the offmap.dcg file and the xxx.rds file used in the campaign).

 

Meanwhile, I need to think up a more permanent fix.

 

Share this post


Link to post
Share on other sites

Paul, the spawn/waypoint limit is 1000km from the lower left map origin, anything over this gets moved to the 1000km line when the mission starts. Maybe offmap airfields only need to be within this limit and not beyond it? Could be worth a try?

Share this post


Link to post
Share on other sites
...the spawn/waypoint limit is 1000km from the lower left map origin' date=' anything over this gets moved to the 1000km line when the mission starts. Maybe offmap airfields only need to be within this limit and not beyond it? Could be worth a try?[/quote']

 

Definitely worth a try. Thanks for the info!

 

Share this post


Link to post
Share on other sites
Paul' date=' the spawn/waypoint limit is 1000km from the lower left map origin, anything over this gets moved to the 1000km line when the mission starts. Maybe offmap airfields only need to be within this limit and not beyond it? Could be worth a try?[/quote']

 

The off-map airfields were only set a few tens of kilometers beyond the map edge. I think what Paul was saying was that the formation's last waypoint was being set at the extreme range.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...