Jump to content

A strange problem and solution

IRFC Hawkeye

Recommended Posts

This was a weird one so I thought I'd post it here for others to read.


A couple of weeks ago I started an RoF QMB mission in order to practice or figure something out.  When I pushed my throttle forward to start my take-off roll, nothing happened.  Funny, I had checked my flight controls....elevator, rudder and ailerons all worked.  Mixture and radiator seemed to respond.  Must be a response curve problem for the throttle axis, I thought.


Checked and found nothing wrong there....just no movement.  I also checked the altitude throttle axis on another plane, and that didn't work either.  Uh-oh!


Got out of the game and started DIView.  Normally when a controller isn't working, the windows in DIView for it's axis' won't even be there.  However, they WERE all there for the throttle; just no movement.  The unresponsive axis' were the main throttle levers: X Rotation (Rx), and Y Rotation (Ry).  I'm pretty sure the Z axis (Z), which is the wheel right on the main lever grip, was working, along with all of the other knobs and levers axis'.


Rebooted computer, back into DIView....same problem.  Tried this a couple of times, no dice.


Now I'm really upset....part of the throttle not working, part working?  Has to be within the hardware itself!  Component failure? 


Went to Virpil website to the warranty section.  Scanned my warranty card and made a .jpg out of it, to attach to my message.  Figured I was going to be out of action for a LONG time and started wondering what kind of shipping I'd have to do to get it back to Lithuania for warranty repair.


Just as I was about to hit the message send button, I thought: "they're going to ask me what I've done to troubleshoot and even tell me the stupid things to do, even though they can't possibly be the problem.  I'd better do them first, just to prevent wasting time in this process".


So I moved my monitor out of the way, shut the power switch off on the main power supply, and then disconnected and reinserted the USB plug multiple times, just to make sure the contacts were clean and making well.  Obviously a waste of time, right?  You can't have a USB connection where part of the device works, and part doesn't.  It's all one serial data stream, and one power and ground supply.  Not only that, I always tie down all of my USB connector cables using tie-wraps on the back of my PC, such that each one has slack in it at the connection point and the cable is neither pushing nor pulling on the connector.  Then I make sure that when I push the box back, that nothing is touching or pressing on the cables or connections, so that there's no external pressure on any of them.  I also never use USB extension cables, which add another connection point to go bad, and add signal loss due to the longer wire path.  I always connect the device directly to the motherboard port, and never use a hub.


The connection felt good, very positive, clicked into place and was very straight with nothing pulling on it; perfect just as it was.


Pushed everything back in place making sure nothing touching, switched the main power supply back on, waited a minute or two, restarted PC.


Guess what....throttle works perfectly in all respects, problem solved.  What the?   :huh:


So you tell me how the hell an imperfect connection can cause only PART of a device to not work, while the rest of it works.


One to file away for the future, under "improbable" or "misleading".   :rolleyes:



Link to comment
Share on other sites

That is odd, and sounds like an issue I had earlier in the year with a warthog throttle. However, in my case after all the trouble-shooting in the world, I can only come to the conclusion that the sensors went bad.


The thing with my throttle is that the axis will read full 100% until I push it all the way forward and then it suddenly reads 0%. Perhaps the sensors aren't bad, but just loose. Anyone have an idea on how to fix?

Link to comment
Share on other sites

Is that something that happens within a sim, or is it just something you see in DIView?


I noticed some odd jumping around like that on some of my axis, when using DIView.  Before it had acted completely normal, then suddenly some of the axis' seemed to be jerky, or even jump from zero to 100, or whatever.  I came to the conclusion that the readings just weren't registering in DIView, like it was for some reason, bogged down, or too busy, and couldn't keep up with the normal readings.


Anyway, it was a window or windows in DIView called "<device name> Buffered".  By default DIView would open one of those windows for each device.  They record the actions of each device, and you can save them to a file if you want.  In any case, it seemed like this recording was what was bogging things down.  So I disabled that window for the device that seemed to be acting up, and voila....the action on the axis was smooth again in DIView.


I never had an actual problem in any sim; everything always worked normally.  It was just the way DIView was showing it.


I suspect if you have a controller that is accurate and generates a lot of data points (i.e. 65,535, or a large amount of raw data), the recording part can at times bog things down....although, at times it did work normally even with those windows open and working.


I also checked to see if the version of DIView I was using was the most current.  The version that came with my MFG Pedals was the same as the one that came with my Virpil stuff.  I am guessing they don't update it very often.


If it is something that is only happening in RoF, it can be conflicting response curves for the axis that is acting up.  See Butzzell's post from a few weeks ago concerning that.


As for an actual hardware problem, I really don't know if or how often Hall Effect sensors actually go bad....I've had potentiometers most of my life, and even those last virtually forever, unless a connection to one goes bad (cheap, push-on connectors that get loose).  For the time that I've had controllers with Hall Effect sensors, none have ever gone bad (I have had my pedals for a few years now).

Link to comment
Share on other sites

I have sometimes the problem where I do have the Throttle X and Y rotation, but nothing else.

Also the LEDs are off. My battle damage repair is this: take out the USB of throttle and plug it in again.

I hear a beep and I have full control again.


Strange is that while the buttons are still not seen by the game (IL2, FC or RoF) the Windows Control Panel shows everything is working same for the VPC-Joy-Setup.


I found DIView and will install it for checking my devices (thx for another good application)

Link to comment
Share on other sites

If is isn't under warranty, might as well disassemble it and have a look inside, if you're the kind of person who can do that without damaging anything.  Here's a link to a thread in which there are a lot of good pictures of the inside:  Warthog Throttle disassembly


His problem was not the same as yours.  All you can do is look for obvious problems like disconnected or broken wires....probably the most likely place would be at the spots where components move.


This guy seemed to imply the mainboards inside the unit going bad was a "known problem".  He also mentioned the price from TM incl. shipping was around "48 Euros" at that time.  Your problem could be completely different.


The pictures also show a lot of plastic screw hole threads that broke on disassembly.  All you can do is be careful when unscrewing, but if they over-tightened them during assembly, not much you can do about that except repair them afterwards.


I'm sure you know at least a few guys in our unit have the TM Warthog Throttle or the entire HOTAS.  I know Pfeil and Loopy have it, probably more.  I doubt they've had troubles, but maybe they've heard things from others.

Link to comment
Share on other sites

Just another guess, but have you tried reloading the firmware?  Some have said it can get wiped....


Firmware Load


Read the whole thing 'cause it tells you to do some things that do not follow the screen prompts....also the throttle seems to have it's own section, so maybe you could skip the stick part.


Not sure how old that document is, there might be something newer so check around.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...