Jump to content
Sign in to follow this  
Luftritter

Windows 10 ver. 1809

Recommended Posts

Wondering if anybody has already updated to this or is running this. Previous version is 1803. I've been caught up with updates since I got back from vacation, and just yesterday I checked for updates, and up comes a "Windows Feature Update". Uh-oh! I hate those; an entirely new version of Windows. Why do they have to do that so often?

Anyway, just like when I was trying to update to version 1803, it didn't work; same symptom too... only this time, I do NOT have "quick boot" enabled in the BIOS. Still, it locked up during the BIOS load, and after killing it and restarting, it booted back up into Windows ver. 1803, with an error code for a failed update.

I went to the MSI website and checked the BIOS section, and they have one version newer than what I'm running (a beta version). Guess what the note said. "Improves stability with Windows version 1809".

I'll report back when I get a chance to try this.

Share this post


Link to post
Share on other sites

I haven't tried anything yet.  Haven't wanted to cause any breakdowns during FiF season.  Updating is far on the back burner, now.  It's going to happen in conjunction with some other hardware things I want to maintain....a couple of replacement fans, getting rid of an add-in card I'm having issues with, etc.  Ultimately, regardless of the reasons for finickiness, I've pretty much had it with this MSI motherboard that I've been using the past couple of years.  The onboard USB has been very unreliable, and that causes me a lot of headaches.  If the latest BIOS updates doesn't change that, I think I'm going to build a new machine, at least a new motherboard, CPU and memory (going with a Gigabyte MB this time); I can keep my video card going for a while longer.  Not sure about the SSD....it's a good one but there are newer ones now, and they're expensive.

 

I'd like to hang on for at least the rest of the year, but these problems are getting me down.

Share this post


Link to post
Share on other sites

No issues here.

 

ASUS Maximus IX Hero Motherboard here and I'm very happy with it. I've only had ASUS MBs for many years and haven't had any problems (but I basically know nothing... went with PC Gamer recommendations    :huh: ).

Share this post


Link to post
Share on other sites

Update on this.

I never did get updated from 1803 to 1809.  1903 came out, and so of course I skipped 1809 and tried to install 1903....that was way back in around May, 2019.  That version wouldn't install either, showing an error code just like the other.

At that point, I just said screw it....I'm not trying to install "feature updates" anymore.  I just let the regular updates to version 1803 install when they came.

'Round about a month ago, I started seeing indications that support for 1803 was going to end in November.  Well, let the chips fall where they may, I figured.  What exactly is "support" anyway?  A bunch of updates you don't even need.  Ya, ya, security.  Well I've never had a virus in my life, although others in my family have.  I just don't open attachments in emails or anything I don't KNOW somebody is sending to me; and I stay clear of shady websites.  The sites I go to are pretty limited and I know they're safe.  I have zero anti-virus installed, except what's part of Windows.  So, I was all ready to keep this 1803 version for as long as I still had this hardware; and all that time, after it initially failed to install, it never asked me to install version 1903 again.

Well today I powered up, and checked the usual notification about updates needed; and today, at the top of the list, was "feature update version 1903".  So I said what the hell, the worst that will happen is that it won't install again, and revert back to version 1803.

Long story short, it installed without a hitch; it took a long time, basically like a new install from scratch.  I even left for a while and checked later.  I didn't have to change any setting in the BIOS.  I didn't have to update the BIOS to a newer version.  I didn't have to disconnect any hardware.  I just let it run as-is; and it worked.  What does that tell you?  I don't know what their trip is with these feature updates that don't install, but it's obvious they can be made to work right if they try.  Hell, it only took them a little over 6 months to get it to work on my machine, which has absolutely nothing unusual about it.

I can hardly wait for the next one in a little less than 6 months.

🙄

Share this post


Link to post
Share on other sites

Luft, you might try updating to the latest Nvidia driver.   One just came out yesterday that I haven't tried, but the one before that was one of the better drivers for my 1080. 

Here's a link to a clean version of the latest with some of the junk removed: https://forums.guru3d.com/threads/441-12-clean-version.421390/

 

 

Share this post


Link to post
Share on other sites
3 hours ago, Labroisse said:

Luft, you might try updating to the latest Nvidia driver.   One just came out yesterday that I haven't tried, but the one before that was one of the better drivers for my 1080. 

Here's a link to a clean version of the latest with some of the junk removed: https://forums.guru3d.com/threads/441-12-clean-version.421390/

As posted elsewhere, I did already update to that newest driver.  It didn't really change anything.

I turned on my monitor's FPS counter and it showed frame rates in the 40's and 50's area.  Way down from basically what it used to be, always near the max of 100 for my G-sync monitor.

I tried various changes to the nVidia Control Panel settings, but nothing improved anything.

The only thing that actually helped was to downgrade some RoF game video settings, such as as forest view distance, and grass quality.  Really?  A game this old, and a 1080 card to boot, and I have to turn the settings down to get smooth play.  BS!  FPS went up to the 60-70 range....very playable, but not what it once was.

I don't know what they did to Windows but there must be a lot higher CPU demand for some reason.  I noticed that there was no turning on or off of Capture Enable anymore in the "Win-G" settings, but still you can capture video (I don't know how much).  That leads me to believe it's recording everything, all of the time, no matter what.

It's F'd up, compared to what it used to be, that's for sure.  Change, for the sake of change.  I can hardly wait to see how screwed up FC is compared to what it was like before, which for me was damned good.

Message to Microsoft:

 

😂

Sorry Klai, couldn't resist.  Delete/move/censor as required....

😁

Share this post


Link to post
Share on other sites
On 11/5/2019 at 7:46 PM, Luftritter said:

I don't know what they did to Windows but there must be a lot higher CPU demand for some reason.  I noticed that there was no turning on or off of Capture Enable anymore in the "Win-G" settings, but still you can capture video (I don't know how much).  That leads me to believe it's recording everything, all of the time, no matter what.

A recent "cumulative update" for version 1903 seems to have improved or even cured the degraded performance I was having in RoF.  No other changes made.

Share this post


Link to post
Share on other sites

Hey Luft, I went through the same hassle trying to update my win10 machine I use for racing finally had to resort to this to get it to take.

 

 

Now it's time to update my main computer from win 7 to 10 which I've been avoiding because I understand my CH equipments software which I use all the time, will from what I've been reading cause conflicts. If worse comes to worse I may have to set up a dual boot but that's not the route I want to go

I see you guys have a thread on the subject, will check it out.

 

Still playing ROF eh

Share this post


Link to post
Share on other sites
47 minutes ago, Fawlty said:

Still playing ROF eh

Yup; and still having fun, mainly in FiF.  FC too, but it will be more so once organized events get started; had a lot of fun in Black September, there.

Thanks for the info, I'll have a look at it!  Good to hear from you again!

S!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...