Jump to content

Force DirectX 11 in Steam VR


Labroisse
 Share

Recommended Posts

Forcing DirectX 11 in Steam VR has helped my VR performance and clarity tremendously in both DCS and IL-2.  Instantly got about 15-20 FPS increase and was able to turn off motion reprojection and also increase the resolution.  Using Reverb G2 with 2080TI.  I'm now getting consistently about 50-60 FPS, no stutters.  In IL2 I have MSAA at 4 with everything else pretty much maxed out.  Still playing around with DCS but this definitely increased performance dramatically there too. 

It is a setting in the VR Dashboard, not in the Windows Desktop Steam VR settings.  Have to get to it using your VR controllers.  For me pressing up or down on controller thumbstick while steamvr is running (game not running) brings it up.  Setting is in the little "settings" gear icon.

Link to comment
Share on other sites

I tried :

- turning on headset

- start steamvr

-start controllers (which appeared in the steam vr environment)

Tried all possible movements of both controller sticks and all buttons, but I could not get any response other than the normal vr menu which does have a gear, but it just takes you to windows settings.

Did I miss anything?

Link to comment
Share on other sites

Hmmm, I'm not seeing either of these options.  

What is the starting point from which you access the "VR Dashboard" ?   Is that a separate software?

I also don't see the \MixedRealityVRDriver\ folder in the path Snaggle quotes.

 

Link to comment
Share on other sites

I finally figured out the dashboard.   I had turned it off when I started using VR because I couldn't figure out how to close it once it was on screen, then completely forgot about it.

I've re-enabled it and found that I can let it start with SteamVR and close it by pointing a controller off of the dashboard and pulling the trigger.

Forcing DX11 didn't make a difference for me in my acid test (FC - "Airfield Defense" mission, 15+ AC and buildings nearby).   50-60 fps at the start of the mission is what I had been getting.   I'll keep observing in FPSVR.

Never have found that .exe.....

Link to comment
Share on other sites

@Jaus check your steam library and see if you have a program called "windows Mixed Reality for SteamVr [beta] installed. I suspect that is the reason you don't see the ..\MixedRealityVRDriver\bin\win64\OpenVRSettingsUX.exe in your folder list.

Link to comment
Share on other sites

If you got the menu to change "force dirext11" in SteamVR/WMR for SteamVR , the .exe to run this program must be somewhere. As you already could have opened the menu in VR, it´s just about solving this mystery of the missing .exe 😄  So next guess is, that you might have redirected the games and apps downloaded through Steam to be installed on another partition of your system? 
I got this .exe linked to the desktop, so it is easily to open, without using VR in the headset ( meanhwile I don´t use Steam, SteamVR and WindowsMixedReality for SteamVR at all anymore ). There´s nothing wrong to do things one way or the other.

Maybe, if you got "Windows Mixed Reality for SteamVR" listed in the library, there is a way to see more information about this entry in the list to get the path to the folder where it is installed? 

 

 

Link to comment
Share on other sites

4 hours ago, Gus said:

Maybe, if you got "Windows Mixed Reality for SteamVR" listed in the library, there is a way to see more information about this entry in the list to get the path to the folder where it is installed? 

Right click on "Windows Mixed Reality for SteamVR" -> properties -> local files

image.thumb.png.01b3249c18825142a07b1f27e79cb3af.png

Link to comment
Share on other sites

On 5/24/2022 at 11:12 AM, Vonrd said:

This is what I have:

C:\Program Files (x86)\Steam\SteamApps\common\MixedRealityVRDriver\bin\win64\en-GB\OpenVRSettingsUX.resources.dll

I found it. Had to scroll to the bottom here: C:\Program Files (x86)\Steam\SteamApps\common\MixedRealityVRDriver\bin\win64\  below all of the folders. 

I opened the .exe and it brings up settings. "Force DX11 Mode" was off. I enabled it, restarted SteamVR and it's now enabled. That should be all I need to do.. right?

StaemVR.jpg

StaemVR2.jpg

Link to comment
Share on other sites

15 hours ago, Gus said:

Maybe, if you got "Windows Mixed Reality for SteamVR" listed in the library, there is a way to see more information about this entry in the list to get the path to the folder where it is installed? 

 

 

That was it.   I had completely forgotten I had installed some steam apps in a different hard drive.   Thanks, I see the .exe now.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...