Jump to content

Recommended Posts

Ive been all over the forums reading of this issue & have yet to find a solution so decided to poll this group for hidden knowledge. 

I had been flying IL2 since its 1st release without issue but 2 patches ago it suddenly stopped working. When I fire it up I get the black screen where it displays "Loading IL2" at the top then I get a CTD. Ive tried all the solutions found on the forums (delete user folder, do steam repair, turn off all overlays & complete reinstall) & so far nothing works. I have noticed there are a percentage of players that have the exact same issue also without resolution. The only thing I have not tried is to run it stand alone (not through Steam). 

Before I delete it off Steam & buy the stand alone version in the desperate hope it will suddenly work does anyone have any ideas? 

Link to post
Share on other sites

Poking around on the net, one person says there problem stemmed from EVGA Precision software running in the background.  They recommended stopping the cards software and seeing if the game then loaded.

Another user said that they had a similar problem, and that it landed up being an audio driver.

Not sure if that helps at all.

Link to post
Share on other sites
  • 4 weeks later...

I’ve also read that you can have problems if you are running W10 Creators Edt. and have MSI Afterburner.  The recommendation is to close down MSI afterburner before launch.

If you have GeForce Experience on, also switch it off before launch.

Link to post
Share on other sites
On 3/28/2021 at 8:15 AM, Lipfert said:

Kameraden,

I'm having DX11 crashes, just started last week. Pretty much every time I fly now. Just started reviewing today. I have been using EVGA Precision to turn up the fans on the card.

S!

Lip,  Try repairing all the Visual C++ installs through Control Panel/Programs and Features (some of the older ones you can't repair), then try and install all the Visual C from the VCRedist directory in the game directory.  If you already have a newer version they won't install but that should be ok. Then uninstall the graphics driver using driver cleaner (from SAFE boot) and reinstall latest Nvidia driver.  I had the same problem when I came back after my move and that seemed to fix it.

Link to post
Share on other sites
11 hours ago, Labroisse said:

Lip,  Try repairing all the Visual C++ installs through Control Panel/Programs and Features (some of the older ones you can't repair), then try and install all the Visual C from the VCRedist directory in the game directory.  If you already have a newer version they won't install but that should be ok. Then uninstall the graphics driver using driver cleaner (from SAFE boot) and reinstall latest Nvidia driver.  I had the same problem when I came back after my move and that seemed to fix it.

Labroisse,

You had the same DX11 Device Removed error?

VCRedist re-installs done. DDU used to clean NVIDIA install, fresh install completed. Tested last night with all secondary app's disabled and I got through two missions.

I did apply the Regedit delay fix for DX11 Device Removed.

S!

Link to post
Share on other sites
3 hours ago, Lipfert said:

Labroisse,

You had the same DX11 Device Removed error?

VCRedist re-installs done. DDU used to clean NVIDIA install, fresh install completed. Tested last night with all secondary app's disabled and I got through two missions.

I did apply the Regedit delay fix for DX11 Device Removed.

S!

I can't say for sure it was "device removed" error but it was a DX11 related crash.  Hope it works for you.

Link to post
Share on other sites

@Yogi

From the Game Setup and Setings FAQ on the IL2 forum, found here: https://forum.il2sturmovik.com/topic/2074-game-setup-and-settings-faq/#faq13

13) Game crashes to desktop all the time, what's wrong?
Find the catalog where the game is installed, enter the folder properties and remove the tick from Read Only field.

Link to post
Share on other sites
2 hours ago, US103_Tobin said:

@Yogi

From the Game Setup and Setings FAQ on the IL2 forum, found here: https://forum.il2sturmovik.com/topic/2074-game-setup-and-settings-faq/#faq13

13) Game crashes to desktop all the time, what's wrong?
Find the catalog where the game is installed, enter the folder properties and remove the tick from Read Only field.

 

1 hour ago, Yogi said:

I got it working by unlinking my acct from Steam & downloading it direct. 

Hopefully this thread will help others who are having the same problems!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...