Jump to content

PTT Issue in TS


Vonrd

Recommended Posts

I posted this in the TS forum:

Just installed TS3 on a new build (TS3 has worked fine on my old build).
When I try to set the PTT hotkey from my HOTAS, it recognizes it but when I hit Enter (or left mouse) to save it it always adds +enter (or +left mouse button) to the selection.

Any suggestions? Can hotkeys be manually edited in one of the files? If so, where and which file.

There were similar posts going way back through 2020. This was the general response from TS:

TS.ChrisRTeamSpeak Staff

Feb '20

Joystick and Gamepad support is not included yet. We are working on that.

I have no Idea why it was working fine on the old machine.

I can set a single press on any keyboard key but that means I have to remove my hand from the throttle or joystick and hunt for that key while in VR. That's not gonna be an option for me. Unfortunately, it looks like I'll have to use VAC from now on. I'll try not to breath too heavily.

 

Link to comment
Share on other sites

9 minutes ago, Pfeil said:

Do you use some Joystick management software like Target?

 

I have to use the VPC configuration tool to configure the throttle but all calibrations / settings are saved in the device itself. The VPC tool is not running unless changes need to be made. Even my Thrustmasted MFD acts the same way and it has absolutely no interconnected software.

 

Link to comment
Share on other sites

I'm not the only one with this issue. This thread goes way back to May 2020. TS response has been BS and many of these people are justifiably pissed off. Most issues seem to happen after a PC upgrade or new build. I bit the bullet and am using JoyToKey to make the Hotas button emulate a keystroke. It works but I have to go through all of my control settings to make sure my choice of "Q" isn't mapped to something... especially "Eject" 😲

https://community.teamspeak.com/t/hotkey-on-gamepad-joystick-steering-wheel-can-not-be-set/8316

Link to comment
Share on other sites

40 minutes ago, Moxy said:

Von if this helps "Q" is 1 command that "isnt" assigned in DCS. "insert" is another. But Check to be sure.

Actually there were several categories / modules that use "Q". I went through all of them (even the ones I don't currently fly, just to be sure, and deleted all. Same in IL-2. I'll have to remember to go through other games like Tobruk, MSFS, etc to check for "Qs".

Link to comment
Share on other sites

Nope, same issue tonight. PTT doesn't work. Keyboard "Q" does but trying to locate that key while in VR is not an option for me.

So far it looks like I'll only be able to use TS as Voice Activation. I refuse to fly that way.

I can only use TS for the initial meeting. Will have to use Discord for flying. I'm sorry to be the instigator for not using TS actively but I've tried everything that I can. I'm really pissed at TS management for not doing ANYTHING about this issue since it seems that it affects many users since 2020.

Link to comment
Share on other sites

Honestly, we should be using Discord anyway.

Our need for the cross comms that TeamSpeak3 gives us isn't as crucial anymore since we use SRS for both IL-2 and DCS.

Additionally, TeamSpeak is going to change really soon, and will probably stop supporting the version we use. And with that, the cross-comms options are probably going to go away.

And most importantly, everyone is on Discord and watching our activity levels.  So, for "branding purposes," it's probably better to be on Discord.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...